Resolved
We have improved the connection pool configuration and improved monitoring to prevent similar issues in the future.
Identified
We have identified the fix and are deploying a fix.
Investigating
We are seeing issues with database connections and are investigating the root cause.